MySQL无法启动常规检查方法

陆伍
2小时前发布 /正在检测是否收录...
广告 广告 广告 广告 广告 广告 广告 广告 广告 广告

注:mysql挂的原因很大程度是重启服务器所致,没事请不要重启服务器,如修改过配置文件等,重载服务即可无需重启。确实需要重启请使用面板中的安全重启,切勿使用reboot命令。

进入ssh 输入df -h 检查是否磁盘空间不足导致mysql服务无法正常启动

df -h

图片[1] - MySQL无法启动常规检查方法 - 陆伍博客 - 你的互联网资源库

进入ssh输入free 检查是否内存不足导致mysql服务无法正常启动

free

图片[2] - MySQL无法启动常规检查方法 - 陆伍博客 - 你的互联网资源库

进入ssh输入ll /www/server/ 检查data目录(数据存放目录)mysql目录(数据库目录)用户是否为mysql

ll /www/server/

如不是可以输入以下两条命令更改所属用户

chown -R mysql:mysql /www/server/data
chown -R mysql:mysql /www/server/mysql

图片[3] - MySQL无法启动常规检查方法 - 陆伍博客 - 你的互联网资源库

进入ssh 输入vi /etc/my.cnf 检查配置文件是否存在

vi /etc/my.cnf

如存在会显示成这样

图片[4] - MySQL无法启动常规检查方法 - 陆伍博客 - 你的互联网资源库

不存在则

图片[5] - MySQL无法启动常规检查方法 - 陆伍博客 - 你的互联网资源库

如都没问题 需要分析错误日志

输入cat /www/server/data/*.err 查看错误日志

cat /www/server/data/*.err

图片[6] - MySQL无法启动常规检查方法 - 陆伍博客 - 你的互联网资源库

图片[7] - MySQL无法启动常规检查方法 - 陆伍博客 - 你的互联网资源库

喜欢就支持一下吧
点赞 0 分享 赞赏
评论
当前页面的评论已关闭
广告